LDAP connection resets results in Desktop Client hanging and in Not responding state
search cancel

LDAP connection resets results in Desktop Client hanging and in Not responding state

book

Article ID: 404662

calendar_today

Updated On:

Products

ESP dSeries Workload Automation

Issue/Introduction

Users that are Remote (LDAP) need to be authenticated by LDAP.  If there is a connection issues, the Desktop Client may hang.

Environment

Workload Automation DE: Any

Cause

Remote or LDAP users need to be authenticated by LDAP.  If there is a network issue or connection reset, then that will sometimes hang the client.

Resolution

The network should check (sniffer) the connection / traffic for any connection resets from DE server to LDAP.  Following is a Java debug example of a connection reset done by LDAP server.  

javax.net.ssl|WARNING|07 9D|Thread-207|2025-06-01 00:12:34.50 EDT|SSLSocketImpl.java:1542|handling exception (
"throwable" : {
  java.net.SocketException: Connection reset

javax.net.ssl|WARNING|6F C3|WSS_cmd_executor_839|2025-06-01 00:12:34.50 EDT|TransportContext.java:249|Warning: failed to send warning alert CLOSE_NOTIFY (
"throwable" : {
  java.net.SocketException: Broken pipe (Write failed)

The above indicates that LDAP server dropped the connection, this will result in authentication failures.