Images not loading in incidents generated by DLP integrated with OCR
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Images not loading in incidents generated by DLP integrated with OCR

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Article ID: 404638

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Updated On:

Products

Data Loss Prevention Core Package Data Loss Prevention Network Monitor and Prevent for Email and Web Data Loss Prevention Sensitive Image Recognition Data Loss Prevention Network Prevent for Email Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

When viewing DLP incidents generated with the participation of an OCR, which should include images that produced the incident matches, the images are not loading. Instead of the image thumbnail and full image, you see an icon of an image that failed loading. This will look similarly to below:

Environment

A DLP-OCR integration can produce incidents based on text content extracted from images. This will produce DLP incidents that include the source images, from which the OCR was extracting text for DLP evaluation, inside the incident snapshots. 

In the Matches section, there will be a thumbnail of the image. It can be clicked to display the image in full size and resolution.

Cause

This can be caused by the role of the logged-in user missing permission to view Attachments on the incidents. This setting can be found in the role configuration panel under General -> Incidents -> Display Attributes -> Shared -> Attachments

Resolution

  1. Log into Enforce and go to the page System -> Login Management -> Roles
  2. Re-enable access to incident attachments for the relevant role.
  3. Save the role.
  4. Log off and log back to Enforce.
  5. Try to open the same OCR-generated incident.
  6. The images should now be accessible.