Virtual Service Traffic Stops Due to traffic_enabled Flag
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Virtual Service Traffic Stops Due to traffic_enabled Flag

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Article ID: 404622

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

  • Virtual Service (VS) on the Avi Load Balancer may stop receiving traffic if the traffic_enabled flag is set to false
  • Avi will not respond to arp requests if this flag is set to false.(vCenter Cloud)
  • VIP Static Route will be removed from the NSX-T manager(NSX-T Cloud)

Cause

The traffic_enabled flag was not enabled (set to false), which caused the Virtual Service to stop receiving traffic. 

Resolution




To restore traffic functionality:

  1. Log in to the Avi Controller UI or use API/CLI.

  2. Locate the affected Virtual Service.

  3. Set the traffic_enabled flag to true.

Once this flag is enabled, traffic to/from the Virtual Service should resume as expected.

 

Events from UI:

This shows that flag was disabled by admin user.




 

How to Check the Flag Status (via UI)

Expected Output: Traffic Enabled flag should be Checked.

 


 


How to Check the Flag Status (via CLI) (
vCenter Cloud or L2 scale out setups)

Expected output: