Unable to Register License in VCF Operations in Connected Mode
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Unable to Register License in VCF Operations in Connected Mode

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Article ID: 404593

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Updated On:

Products

VMware SDDC Manager / VCF Installer VCF Operations

Issue/Introduction

  • Registering VCF Operations in VCF Business Services console in connected mode fails without error but VCF Operations activation status shows as "activation pending"
  • You are able to register VCF Operations with VCF Business Services console only in Disconnected mode: Register VCF Operations in Disconnected Mode
  • You are unable to switch from Disconnected to Connected Mode: Switch from Disconnected to Connected Mode
  • Error visible on Registration page: Switching the reporting mode failed. Check your Internet connection. If the problem persists, enter a new activation code in VCF Operations by using the Actions menu on this page. If the problem is not resolved, contact support.
  • Unable to complete VCF Operations registration in connected mode. The 'start registration' button spins indefinitely and fails to navigate to https://vcf.broadcom.com, even with internet connectivity.
  • You will see similar error in the /storage/log/vcops/log/vcf-licensing-plugin.log file 

    ERROR license-usage-plugin #### [ops@#### threadId="####" threadName="ServerConnection on port 10000 Thread ##"] [com. vmware. vrops. license.usage. server. LicenseUsageServer. checkLicenseCloudIntegrationConnectivity] - Failed to check license cloud integration connectivity
        java.net.SocketException: Network is unreachable

Environment

VCF 9.x

VCF Operations 9.x

Cause

There is a proxy enabled in the environment.

Proxy or firewall are blocking required URLs for validating licenses.

Resolution

Ensure your VCF Operations can access these URLs:

NameVersionsURL (port)Purpose
VCF Business Services console licensing9.x

vcf.broadcom.com (443)

eapi.broadcom.com (443)

License usage submission and license downloads (connected only)

For information on network connectivity requirements for VMware products, see https://ports.broadcom.com/home
 
This connection can also be manually tested from your VCF Operations server by using the commands below:
 
curl -v https://vcf.broadcom.com
curl -v https://eapi.broadcom.com