Updating HCX Migration Maintenance window schedule is not adhered to
book
Article ID: 404555
calendar_today
Updated On:
Products
VMware HCX
Issue/Introduction
After updating/changing the "SCHEDULE" from HCX Manager UI, the migration did not start on the scheduled time/day.
Ignoring the failover window also would not start the recovery.
When you create a "reverse" HCX Bulk or RAV migration on HCX Manager 4.10 to HCX Manager 4.11, you cannot update the initially created maintenance window from the source HCX Manager (4.10).
Validated that the reschedule job is created on both source/target HCX Managers by reviewing the file /common/log/admin/app.log: Source HCX-MGR (4.10.3):
<timestamps> UTC [MobilityMigrationService_SvcThread-33905, Ent: HybridityAdmin, , TxId: ########-####-####-####-############] INFO c.v.h.s.m.j.MobilityMigrationRescheduleJob- Starting to Run Job(########-####-####-####-############):BEGIN
Target HCX-MGR (4.11):
<timestamps> UTC [MobilityMigrationService_SvcThread-30645, Ent: HybridityAdmin, , TxId: TxId: ########-####-####-####-############] INFO c.v.h.s.m.j.MobilityMigrationRescheduleJob- Starting to Run Job(########-####-####-####-############):COMPLETE
Environment
VMware HCX 4.10 (Source)
VMware HCX 4.11 (Target)
Cause
This issue only impacts reverse migrations originating from a 4.10.x HCX Manager to a 4.11 HCX Manager.
Due to an internal issue with HCX Migration processing workflow for reverse migration, the reschedule job initiated from source HCX Manager on 4.10 does not get applied on the target 4.11 HCX Manager.
Resolution
Upgrade the source HCX Manager to 4.11.
Workaround:
Avoid modifying the switchover schedule via source HCX Manager (4.10) and instead modify the schedule from target/cloud Manager (4.11).
When modifying the switchover schedule from target HCX Manager, the proper Maintenance window schedule is reflected on the migration UI page both HCX Managers .