Unable to log in to the Usage Meter Web UI — the screen briefly displays Loading... and eventually returns to the login page without completing the login.
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Unable to log in to the Usage Meter Web UI — the screen briefly displays Loading... and eventually returns to the login page without completing the login.

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Article ID: 404438

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

  • Unable to log in Usage Meter Web UI .

    After entering the login username and password, the screen briefly displays "Loading..." and eventually returns to the login page without logging in.
  • You will be unable to login to the Usage Meter VAMI page as well.
  • In vmware-um-login.service.log you see errors similar to the following:
    YYYY-MM-DDTHH:MM:SS  INFO 908 --- [VCF Usage Meter Login Service] [ient-1-Worker-0] o.b.jsse.provider.ProvTlsClient          : [client #### @#####af] opening connection to xxx:5480
    YYYY-MM-DDTHH:MM:SS  INFO 908 --- [VCF Usage Meter Login Service] [ient-1-Worker-0] o.b.jsse.provider.ProvTlsClient          : [client #### @#####af] raised fatal(2) certificate_unknown(46) alert: Failed to process record
    org.bouncycastle.tls.TlsFatalAlert: certificate_unknown(46)
                  at org.bouncycastle.jsse.provider.ProvSSLEngine.checkServerTrusted(ProvSSLEngine.java:154)
                  at org.bouncycastle.jsse.provider.ProvTlsClient$1.notifyServerCertificate(ProvTlsClient.java:382)
                  at org.bouncycastle.tls.TlsUtils.processServerCertificate(TlsUtils.java:4830)
                  at org.bouncycastle.tls.TlsClientProtocol.handleServerCertificate(TlsClientProtocol.java:797)
    Caused by: java.security.cert.CertificateException: No name found matching xxx
                  at org.bouncycastle.jsse.provider.HostnameUtil.checkHostname(HostnameUtil.java:108)
                  at org.bouncycastle.jsse.provider.ProvX509TrustManager.checkEndpointID(ProvX509TrustManager.java:329)
                  at org.bouncycastle.jsse.provider.ProvX509TrustManager.checkEndpointID(ProvX509TrustManager.java:448)
                  at org.bouncycastle.jsse.provider.ProvX509TrustManager.checkExtendedTrust(ProvX509TrustManager.java:357)
                  ... 24 common frames omitted
    YYYY-MM-DDTHH:MM:SS  INFO 908 --- [VCF Usage Meter Login Service] [ient-1-Worker-0] o.b.jsse.provider.ProvTlsClient          : [client ##### @#####af] disconnected from xxx:5480
    YYYY-MM-DDTHH:MM:SS  WARN 908 --- [VCF Usage Meter Login Service] [nio-8050-exec-2] c.v.v.u.a.p.PamAuthenticationProvider    : Unable to make HTTP call to VAMI API
     

Environment

VCF Usage Meter 9.X

Cause

This issue will occur, if the DNS entries are incorrectly set in the VAMI page and there are certificate issues.

Resolution

  • Make sure that hostname and DNS resolves IP address to a domain name matches.
  • Take SSH to the Usage Meter and verify the hostname
    echo $(hostname)
    bash /usr/bin/lookup-hostname.sh
  • Add the hostname in /etc/hosts file
VCF Usage Meter Appliance 9.0.0.0-24699491.
usagemeter@Testlab [ ~ ]$ cat /etc/hosts
# Begin /etc/hosts (network card version)
##.##.##.## example.com
12.7.0.0.1 localhost. localdomain
127.0.0.1 localhost
127.0.0.1 photon# End /etc/hosts (network card version)
usagemeter@Testlab[ ~ ]$
  • Check, if the DNS is set correctly using nmctl show-dns command.
  • If the DNS is not set correctly, update the DNS using nmctl set-dns command.
  • Also, replace the certificates using the certificate management document Certificate Management

Post making the above changes, you should be able to login to the VAMI page of the Usage Meter.

Once logged into the VAMI page, Navigate to Networking tab and update the DNS servers and hit save.

Post making above changes, you should be able to login to the web interface of the Usage Meter.