" no healthy upstream" error present when attempting to login to login to Aria Automation UI
search cancel

" no healthy upstream" error present when attempting to login to login to Aria Automation UI

book

Article ID: 404418

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When attempting to login to the web UI for Aria Automation, the login fails and on the web page there is an error that states " no healthy upstream"
  • Output of deploy.sh contains the following error:

    Running check non-default-hostname
    Running check eth0-ip
    Running check single-aptr
    make: *** [/opt/health/Makefile:38: single-aptr] Error 1

  • identity-service-app pods remain at 0/1 Running/Pending

Environment

Aria Automation 8.x
VMware Identity Manager 3.3.x

Cause

  • A health check is performed during service start for both forward and reverse DNS lookups. This error can occur when the PTR record is missing in DNS or incorrect for the Aria Automation, Aria Automation Orchestrator, or VMware Identity manager appliances.
  • Degraded services on the vIDM due to DNS resolution failures.
  • After initiating a system reboot of the vIDM cluster or the vRA cluster for normal maintenance operations, the DNS service becomes degraded as the DNS info is pointing to incorrect name servers.
  • Persistent vAPP settings in vSphere cause the name servers to revert to old expired DNS IP addresses.

Resolution

  • Update DNS info with correct server IP addresses under
    • vCenter vApp Options for the appliance VM(s) under vami.DNS.vRealize_Automation. Note: you must power off the appliance first to be able to change this setting.
    • /opt/vmware/etc/vami/ovfenv.xml
      • Edit the line that starts with <Property oe:key="vami.DNS.vRealize_Automation" oe:value="<DNS IP,DNS IP>"/>
    • /etc/resolv.conf
  • Ensure that at the bottom of this file right above search . where it says nameserver <DNS IP> that the IP addresses are correct. 

         Note: the ovfenv.xml file only applies to vRA and doesn't exist in vIDM. 

         Additional Details:
         vRA requires editing the vApp setting in vCenter first, followed by ovfenv.xml file, and finally vracli network dns set --servers DNS1,DNS2 command.

         vIDM requires editing the vApp setting in vCenter first, followed by the resolve.conf file.

         Note: A reboot of the appliance is required after making changes to the ovfenv.xml and resolv.conf files to ensure the setting changes stick.


For properly setting DNS so that it persists through reboots see the following articles:

Additional info on setting all DNS info:
https://knowledge.broadcom.com/external/article/370826