Unable to update the AD SSO Bind
search cancel

Unable to update the AD SSO Bind

book

Article ID: 404394

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

When trying to add or update an LDAP identity provider (after changing the AD Account password) through SDDC Manager, an error is thrown.

Environment

VMware SDDC Manager 4.x

VMware SDDC Manager 5.x

Cause

The AD account being used to create the identity source bind in SDDC Manager has the following characters in the password:   ` @ % ^ & < >

This is due to the SDDC Manager UI not being able to escape the specific special characters.

Resolution

VMware by Broadcom is aware of this issue and working to resolve this in a future release.

Workaround

  1. Change the password of the AD account being used to exclude the unsupported characters ` @ % ^ & < > and retry the SSO Identity Source Bind in SDDC Manager.