"Error connection Fleet management node, try again" in VCF Operations Admin UI when attempting to connect to new Fleet Management appliance
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"Error connection Fleet management node, try again" in VCF Operations Admin UI when attempting to connect to new Fleet Management appliance

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Article ID: 404388

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Updated On:

Products

VCF Operations

Issue/Introduction

  • This is a new deployment, and the VCF Operations and VCF Fleet Management appliances have been deployed recently.
  • The initial attempt to register the VCF Fleet Management appliance failed with "not connected" when following Register the VCF Operations fleet management Appliance with VCF Operations
  • Attempting to connect the appliance again fails with, "Error connection Fleet management node, try again" or you may receive the error "Unexpected error occurred during request

 /var/log/vrlcm/vmware_vrlcm.log The Fleet Management appliance shows a message similar to:

Exception while creating Environment: com.vmware.vrealize.lcm.lcops.common.exception.InvalidEnvironmentException: Deployment or Import Blocked: You’ve reached the limit of allowed instances for VCF Operations (maximum: 1). Please check your inventory and remove any existing deployed, failed or draft instance(s) to proceed with the new deployment or import
  

  • In the VCF operations appliance shows a message similar to: /storage/log/vcops/log/casa/casa.log.  

    ERROR casa 1526 [####@####threadId="192" threadName="ajp-nio-127.0.0.1-8011-exec-9" requestId="#######"] [com.vmware.vcops.casa.fleetmanagement.FleetManagementNodeService.handleNodeAddition:156] - Exception during node addition: com.vmware.vcops.casa.exception.CasaLocalizableException: CasaLocalizableException: key=fleet.node.management.unexpected.service.error; args=org.springframework.web.client.HttpServerErrorException$BadGateway: 502 Bad Gateway: "<html><EOL><EOL><head><title>502 Bad Gateway</title></head><EOL><EOL><body><EOL><EOL><center><h1>502 Bad Gateway</h1></center><EOL><EOL><hr><center>nginx</center><EOL><EOL></body><EOL><EOL></html><EOL><EOL>"; cause= at com.vmware.vcops.casa.fleetmanagement.lcm.LCMInternalService.doLcmCallWithResponse(LCMInternalService.java:135) ~[classes/:?]

Environment

  • VCF Operations 9.0.x
  • VCF Fleet Management 9.0.x

Cause

The initial connection attempt failed due to some error and the second attempt is failing because the Fleet Management appliance has a partial entry for the failed connection.

Resolution

These steps should only be used when the Fleet Manager has never been connected to VCF Operations

Redeploy the Fleet Manager appliance

  1. Remove the VCF Fleet Management appliance from vCenter which is failing to register with VCF Operations

  2. Deploy a fresh VCF Fleet Management appliance. Deploy the VCF Operations fleet management Appliance

    Note: Download a fresh copy of the OVA file to ensure file integrity and rule out potential version mismatches.

  3. Attempt the registration again

  4. If it fails, examine the /storage/log/vcops/log/casa/casa.log in the VCF Operations appliance and the /var/log/vrlcm/vmware_vrlcm.log on the Fleet Management appliance.

  5. Resolve any problem presented in the above logs.

Additional Information

This issue might also occur if you deployed the Fleet Management appliance in a Greenfield Setup, but the DNS configuration did not get applied properly during the OVA deployment. To properly set DNS, follow the KB - VCF Operations Fleet Management loses its networking configuration on reboot or during upgrade to 9.0.1

IMPORTANT: The manual redeployment steps in this article should only be used when the Fleet Manager has never been connected to VCF Operations. If the appliance was previously connected, redeploying using this method may result in stale database records that block the new appliance from connecting.

If you have already performed a redeployment and are unable to connect the node in the Admin UI, facing the error "Error connecting Fleet management node, try again," perform the following checks:

  • Network Configuration: Verify that the DNS settings provided during OVF deployment are valid IP addresses. Do not use NTP FQDNs in the DNS fields, as this prevents the appliance from resolving the VCF Operations primary node.
  • Version Alignment: Ensure the Fleet Management appliance version matches your VCF Operations version (e.g., version 9.0.1 for Operations 9.0.1).
  • Service Status: Confirm the VCF Operations cluster is fully online and analytics are running before attempting the connection.

Persistent Connection Failures
If you are unable to successfully redeploy and continually receive the connection error after verifying the above, you may have stale environment records in the node database. In this scenario:

  • Refer to KB 410260 which currently instructs you to open a case with Broadcom Support
  • The internal steps in KB 410260 provide specific API and database commands to manually clear the VCF Operations instance from the Fleet Manager so it can be re-connected successfully. To ensure data is not lost, this should be done by Broadcom Support.

 

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