No License message or evaluation mode in VMware Cloud Foundation Operations for Logs 9.0
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No License message or evaluation mode in VMware Cloud Foundation Operations for Logs 9.0

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Article ID: 404339

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Updated On:

Products

VCF Operations

Issue/Introduction

  • You have deployed, installed, migrated, updated or upgraded to a VMware Cloud Foundation Operations for logs 9.0 version and have integrated it with an already licensed VMware Cloud Foundation Operations 9.0.
  • In the Management > License page you see a message 'No License' and a banner on top:
    You are in an evaluation mode, which expires on <date>.

  • Edit button mentioned in the documentation Configuring Log Sources is greyed out and the Status column displays "Log collection is not enabled" as per the screenshot below:

 

Environment

VMware Cloud Foundation Operations for Logs 9.0

VCF Operations 9.0

Cause

VCF Operations for Logs 9.0 is not integrated with a licensed vCenter 9.0 server.  For VMware Cloud Foundation Operations for Logs 9.0 to get licensed you must setup an integration with a vCenter V9.0 instance that is licensed with a VMware vSphere Foundation 9.0 license or a VMware Cloud Foundation 9.0 license. Please ensure that you configure at least one vCenter on version 9 as a log source as per Configuring Log Sources to allow VCF Operations for Logs to be successfully licensed.

Note: If you have vCenter servers on V8.0 which is licensed correctly with VCF/VVF license this is expected behavior.

Resolution

  1. Sign into the VCF Operations product UI browse to AdministrationIntegrations 
  2. Locate vCenter adapter instance the adapter instance can be a standalone vCenter adapter instance or it can be included in the VMware Cloud Foundation adapter instance
  3. Edit the vCenter adapter, Log Operations section, and enable Activate Log Collection as per the screenshot below:

Note: The "You are in an evaluation mode, which expires on <date>." can also be encountered if the truststore is corrupted on any one of the VCF Operations for Logs nodes. Refer to the following KB How to replace a corrupted truststore in VCF Operations for Logs to identify and fix the truststore corruption.

Additional Information

9.0 Products and Product Components