HCX Network Extension failed with the error "Unable to find Layer2 Id for segment"
search cancel

HCX Network Extension failed with the error "Unable to find Layer2 Id for segment"

book

Article ID: 404327

calendar_today

Updated On:

Products

VMware HCX VMware NSX

Issue/Introduction

  • After following the steps described in the article HCX Segments Created with NSX-T Manager UI/API not Visible in NE wizard, the following error is observed in the /common/logs/admin/app.log:
    <timestamp> UTC [NetworkStretchService_SvcThread-458, j: 9ea10d55, s: d33d37ab, , TxId: #########-####-####-####-#########] WARN c.v.v.h.networkstretch.AbstractJob- Fa
    iled to resolve vc opaque network moref for logical switch #########-####-####-####-#########: Failed to get opaque network moref with logical switch id #########-####-####-####-#########
    <timestamp> UTC [NetworkStretchService_SvcThread-458, j: 9ea10d55, s: d33d37ab, , TxId: #########-####-####-####-#########] WARN  c.v.v.h.n.i.AbstractJobInt- Exception
    in NetworkStretchJobs:ExtendNetworkWorkflowInt. Reason : Unable to find Layer2 Id for segment /infra/segments/<segment-name>
  • In the HCX Manager UI - Administration - Activity Logs reports, you see the error:
    Unable to find Layer2 Id for segment /infra/segments/<segment-name>

Environment

VMware HCX 4.x
VMware NSX 3.2 or later

Cause

The policy API /policy/api/v1/infra/segments/<segment-id> creates a Segment along with a Logical Switch and populates the VNI in the realized entity. If the policy API is used to create a Segment for an already available overlay-backed Logical Switch, the Segment creation succeeds, but the VNI information is not populated in the realized logical switch.

Resolution

This is a condition that may occur in a VMware HCX / NSX environment.

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information