Some of the performance data about vSAN File Services isn't displayed on vSphere Client.
search cancel

Some of the performance data about vSAN File Services isn't displayed on vSphere Client.

book

Article ID: 404171

calendar_today

Updated On:

Products

VMware vSAN 8.x VMware vSphere ESX 8.x VMware vCenter Server 8.0

Issue/Introduction

vSphere Client shows the following message when you check the performance data about file share from [vSAN Cluster] > [Monitor] tab > [Performance] > [FILE SHARE] tab.
Performance data with the below message is unavailable.

"No data available for the selected period"
"The performance service was not enabled during the selected period."

Environment

vCenter Server 8.0 U3
ESXi 8.0 U3
vSAN 8.0 U3

Cause

This issue is caused by the limitation "VsanSaasVsiDevMetricsSizeLimit" parameter.
The amount of file share performance data that can be displayed depends on VsanSaasVsiDevMetricsSizeLimit setting in vCenter Server 8.0 U3 and ESXi 8.0 U3.

VsanSaasVsiDevMetricsSizeLimit value is 5 by default.
Thus, the amount of file share performance data that can be displayed per cluster is limited up to 5 times the number of hosts in the cluster.
For examples, a cluster which is composed of 10 ESXi shows only up to 50 performance data about file share.

Resolution

This is known issue in vCenter Server 8.0 U3 and ESXi 8.0 U3.
Broadcom engineering is aware of the issue and working to towards permanent fix in future release.

Additional Information

As a workaround, you could modify the value of VsanSaasVsiDevMetricsSizeLimit from 5(default) to 20(max value) on per ESXi.
Command:
# vsish -e set /config/VSAN/intOpts/VsanSaasVsiDevMetricsSizeLimit 20

You can confirm the modification with the following command and its output.
Command:
# vsish -e get /config/VSAN/intOpts/VsanSaasVsiDevMetricsSizeLimit | grep "Current value"