Performance Manager old alarms are not clearing
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Performance Manager old alarms are not clearing

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Article ID: 404170

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Updated On:

Products

Network Observability

Issue/Introduction

The Old alarms are still showing in the CAPerformance Management and unable to clear 

In Spectrum the old alarms are cleared also restarted the One click service also.

Still it is showing the old alarms in CAPerformance Management.

Environment

24.3.x or 23.3.x

Cause

Event Management service is out of sync 

Resolution

To get all the alarm from OneClick again 

1. Event Manager( EM ) service need to be restarted 

service caperfcenter_eventmanager stop
service caperfcenter_eventmanager start

Or

2. Call a SubscriptionUpdateRequest end point to read all the alarms from Oneclick

So you need to do the following

if Event Manager http URL Is
curl -X POST -u USER -H 'Content-type: application/xml' -d'<SubscriptionUpdateRequest><Refresh>true</Refresh><Invalidate>true</Invalidate></SubscriptionUpdateRequest>' http://{PORTALHOST}:8281/EventManager/webservice/alarmservice/subscriptions/refresh


if HTTPS 
URL is:
https://{PORTALHOST}:8282/EventManager/webservice/alarmservice/subscriptions/refresh

Replace the PORTALHOST with the NetOps Portal Server Name