Service Point search returning too many results
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Service Point search returning too many results

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Article ID: 404151

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When searching in Service Point using a Spanish Phrase, the application returns several SDM Areas/Categories and Catalog offerings.

The issue does not occur when searching English words.

Environment

Service Point 17.4 English Installation

SDM 17.4 English Installation

Cause

The search string is in Spanish, and most of the data, including "stop words" are in English, which is not supported (Multilingual is not supported in SDM).

Resolution

We can improve the results by adding the Spanish "stop words" (also known as noise words) to your English installation.

Option 1: Go to a Spanish Installation, Administration tab, select Knowledge, Search, KT Search Engine, Noise Words, and add the Spanish noise words to your English Installation. See steps under "Create Noise Words", restart SDM and xFlow services.

Option 2: Go to a Spanish Installation Database, get the data from ebr_noise_words (with all the Spanish Noise words) and insert into your mdb, same table but with new IDs to avoid replacing existing noise words, and run the knowledge re-index utility to reindex the knowledge base, restart SDM and xFlow services. Engage your DBA for this step and test the steps in your QA/Test environment before applying to production.

Note: Take a backup of the ebr_noise_words before any change to the table.