Endpoint sisamdagent is in not running status
search cancel

Endpoint sisamdagent is in not running status

book

Article ID: 404063

calendar_today

Updated On:

Products

Endpoint Security Complete Endpoint Protection

Issue/Introduction

Symantec Agent for Linux Daemon status shows "sisamdagent          not running"

getagentinfo.log shows 

/etc/profile.d/lang.sh: line 19: warning: setlocale: LC_CTYPE: cannot change locale (en_GB.GBK): No such file or directory
/etc/profile.d/lang.sh: line 20: warning: setlocale: LC_COLLATE: cannot change locale (en_GB.GBK): No such file or directory
/etc/profile.d/lang.sh: line 23: warning: setlocale: LC_MESSAGES: cannot change locale (en_GB.GBK): No such file or directory

Sisis_user_env.txt 

-- /bin/su -s /bin/bash - sisips -c ". /opt/Symantec/sdcssagent/IPS/.profile; set" --
/etc/profile.d/lang.sh: line 19: warning: setlocale: LC_CTYPE: cannot change locale (en_GB.GBK): No such file or directory
/etc/profile.d/lang.sh: line 20: warning: setlocale: LC_COLLATE: cannot change locale (en_GB.GBK): No such file or directory
/etc/profile.d/lang.sh: line 23: warning: setlocale: LC_MESSAGES: cannot change locale (en_GB.GBK): No such file or directory
/etc/profile.d/lang.sh: line 26: warning: setlocale: LC_NUMERIC: cannot change locale (en_GB.GBK): No such file or directory
/etc/profile.d/lang.sh: line 29: warning: setlocale: LC_TIME: cannot change locale (en_GB.GBK): No such file or directory

Environment

Symantec Endpoint Protection Client for Linux 14.3.X


Cause

The locale set on the machine is "en_GB.GBK" which is not installed leading to AMD/ sisamdagent  daemon failure

Resolution

Install "en_GB.GBK" or switch system locale to "en_GB.UTF-8"

Here is the command to switch the system locale 

# localectl set-locale LANG=en_US.UTF-8