vSphere Replication Management Server could not establish connection to vSphere Replication Server at '127.0.0.1:8123'
search cancel

vSphere Replication Management Server could not establish connection to vSphere Replication Server at '127.0.0.1:8123'

book

Article ID: 404040

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • The following Error is noticed on the SRM console

Error: vsr-sdr : vSphere Replication Management Server could not establish connection to vSphere Replication Server at '127.0.0.1:8123'

  • Recent tasks show:

Reconnect vSphere Replication Server | vCenter_FQDN_Name | The object'vim. VirtualMachine:vm-####' has already been deleted or has not been completely created.

  • In the Replication server tab under the SRM Site Pair, the Replication server shows as Disconnected.

  • The hbrsrv.log indicates that the SSL thumbprint mismatch is causing HMS login to fail.

YYYY-MM-DDThh:mm:ss.ms.094+07:00 warning hbrsrv[01004] [Originator@6876 sub=Main opID=########-####-####-####-#############-HMS-PING---Ping Thread for session key: N/A and vmomi session: null and server: 127.0.0.1:8123] HbrError stack:
YYYY-MM-DDThh:mm:ss.ms.094+07:00 warning hbrsrv[01004] [Originator@6876 sub=Main opID=########-####-####-####-#############-HMS-PING---Ping Thread for session key: N/A and vmomi session: null and server: 127.0.0.1:8123]    [0] Invalid login
YYYY-MM-DDThh:mm:ss.ms.094+07:00 warning hbrsrv[01004] [Originator@6876 sub=Main opID=########-####-####-####-#############-HMS-PING---Ping Thread for session key: N/A and vmomi session: null and server: 127.0.0.1:8123]    [1] Unknown client SSL thumbprint 06:FE:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:E1
YYYY-MM-DDThh:mm:ss.ms.094+07:00 warning hbrsrv[01004] [Originator@6876 sub=Main opID=e4601195-0405-431d-85aa-5aebd7671725-HMS-PING---Ping Thread for session key: N/A and vmomi session: null and server: 127.0.0.1:8123]    [2] Error converted to Vmomi fault hbr.replica.fault.InvalidLogin

  • The SSL thumbprint used by hbrsrv does not match the one configured for hms.

  • Run the following command to compare the thumbprint between hbrsrv and HMS.

root [ /opt/vmware/support/logs ]# /usr/bin/hbrsrv-guestinfo.sh get guestinfo.hbr.hbrsrv-thumbprint
06:FE:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:E1

root [ /opt/vmware/support/logs ]# /usr/bin/hbrsrv-guestinfo.sh get guestinfo.hbr.hms-thumbprint
6F:4F:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##::##:##:##:A6

Environment

VMware Site Recovery Manager 8.x

VMware Live Site Recovery 9.x

 

Cause

  • The mismatch in the thumbprint between the hbrsrv and HMS led to the disconnection of the vSphere Replication server.

Resolution

  • Take a snapshot of all the vSphere replication servers.

  • Update the HMS certification thumbprint to match with HRBsrv thumbprint.

root [ /usr/java/default/bin ]# /usr/bin/hbrsrv-guestinfo.sh set guestinfo.hbr.hms-thumbprint 06:FE:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:E1

  • Restart the hbrsrv service on the vSphere replication server. [systemctl restart hbrsrv]

Additional Information