Unable to retrieve pairs from extension server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk.Unable to connect to Site Recovery Manager Server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk. Reason: Unable to download versions
search cancel

Unable to retrieve pairs from extension server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk.Unable to connect to Site Recovery Manager Server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk. Reason: Unable to download versions

book

Article ID: 404036

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • The following Error is noticed on the SRM console post-upgrading the SRM from 8.5 to 8.7/8 and 8.7/8 to 9.0.2 

Error: Unable to retrieve pairs from extension server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk.Unable to connect to Site Recovery Manager Server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk. Reason: Unable to download versions file from Site Recovery Manager Server at https://vcenter_domain_FQDN:443/drserver/vcdr/vmomi/sdk. Http response: HTTP/1.1 503 Service Unavailable. 

  • The SRM tabs will be missing on the SRM console.

  • A Warning Alert will be noticed on SRM console stating: You are currently using the legacy vSphere Replication, which will be deprecated in the next release. Transition over to the Enhanced vSphere Replication

 

  • SRM reconfiguration fails with error : 

ERROR
Operation Failed
A general system error occurred:
N7Vmacore24InvalidArgumentExceptionE service

Verification:

  • Below Error is noticed under VMware-dr.log : 

2025-07-07T05:22:33.597Z panic vmware-dr[60749] [SRM@6876 sub=Default] Application error: N7Vmacore9ExceptionE DBManager error: Product version mismatch.  Runtime version 9.0.2 .  Found schema version 8.5.0 in database.
--> [context]##########################################################################################=[/context]
--> [backtrace begin] product: VMware vCenter Site Recovery Manager, version: 9.0.2, build: build-24639340, tag: vmware-dr, cpu: x86_64, os: linux, buildType: release
--> backtrace[00] libvmacore.so[0x004F186D]
--> backtrace[01] libvmacore.so[0x00252452]: Vmacore::System::Stacktrace::CaptureWork(unsigned int)
--> backtrace[02] libvmacore.so[0x0022B0D7]: Vmacore::System::SystemFactory::CreateQuickBacktrace(Vmacore::Ref<Vmacore::System::Backtrace>&)
--> backtrace[03] libvmacore.so[0x001C192C]: Vmacore::Throwable::Throwable(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&&)
--> backtrace[04] vmware-dr[0x00025616]
--> backtrace[05] vmware-dr[0x000CE12B]
--> backtrace[06] libdr-vmacore.so[0x000B7D86]: Dr::DrApp::Run(std::function<int ()> const&)
--> backtrace[07] vmware-dr[0x000308E0]
--> backtrace[08] libc.so.6[0x00027F0A]
--> backtrace[09] vmware-dr[0x0003149D]
--> [backtrace end]

  • SRM Database table shows 8.5.0 version despite upgrading.

srmdb=> select * from dr_product_info;
     name     | value
--------------+-------
 data_version | 8.5.0
 version      | 8.5.0
(2 rows)

Environment

VMware Site Recovery Manager 8.x

VMware Live Site Recovery 9.x

Cause

  • This issue occurs when the Site Recovery Manager (SRM) upgrade is not completed successfully during the transition from version 8.5 to 8.7/8.8, and from 8.7/8.8 to 9.0.2.

 

 

Resolution

  • Revert the snapshots taken before the SRM upgrade on both the Production and DR sites.

  • Perform the SRM upgrade from version 8.5 to 8.7 or 8.8 on both sites.

  • Reconfigured the SRM pairing with vCenter and confirm the working condition.
  • Take another snapshot before upgrading the SRM to 9.0.2.

  • Proceed to upgrade SRM from version 8.7/8.8 to 9.0.2 on both the Production and DR sites.

Additional Information