The vSphere tag value in the generated report is inconsistent with the vSphere tag data seen in the UI and in the metrics.
The view used in the report shows a previous value for the vSphere tags which is wrong, but reviewing the VM Summary page shows the correct current value for the vSphere tag.
View shows incorrect data for vSphere tag property
Environment
VMware Aria Operations 8.18.x
Cause
Known issue affecting the cached value for property data.
Resolution
The Broadcom development team is working on a fix for this issue to be provided in a future version.
Workaround 1 - Perform a cluster restart
Log in to the Admin UI
Click the Take cluster offline button and wait for the Status to show as Offline
Click the Bring cluster online button
Workaround 2 - Use maintenance mode
Log in to the Product UI and navigate to Operations > Configurations > Inventory Management
Locate the affected object(s) and highlight them
Click the Start Maintenance button
Select the I will return to end maintenance myself radio button and click OK
Click the End Maintenance button
Workaround 3 - Use the Last transformation
Log in to the Product UI and navigate to Operations > Views > Manage
Locate the View used in the report, click the vertical 3 dots button, and select Edit
Click the 2 - Data tab and highlight the row containing the vSphere Tag data
Expand the Configuration panel
Change the Transformation to Last and click Update