Console error saving new analyzer metric definition
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Console error saving new analyzer metric definition

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Article ID: 403981

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Updated On:

Products

Information Centric Analytics

Issue/Introduction

A generic 'Request Failed' dialog box appears in the Risk Fabric console when you save a new Analyzer metric. You tried creating a variety of Analyzer metrics and all produced the same error, though all metrics were created.

The RiskFabric server log (w3wp_RiskFabric.<yyyyMMdd>.log) records the following when this occurs:

[105:ERROR] LoggingExceptionFilterAttribute.OnException() https://<hostname>/api/metricwizard/processmetric?metricKey=2472
System.TypeLoadException: Could not load type 'RiskFabric.Collector.DataAccess.ConnectionSettings' from assembly 'RiskFabric.Collector, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
   at RiskFabric.Web.Controllers.MetricWizardController.ProcessMetric(Int32 metricKey)
   at lambda_method(Closure , Object , Object[] )
   at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.<>c_DisplayClass10.<GetExecutor>b_9(Object instance, Object[] methodParameters)
   at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ExecuteAsync(HttpControllerContext controllerContext, IDictionary`2 arguments, CancellationToken cancellationToken)
— End of stack trace from previous location where exception was thrown —

IIS logging captures the 500 error seen in the browser's developer tools:

2025-05-30 12:13:55 <IP_address> POST /api/metricwizard/processmetric metricKey=2472 443 <domain\account_name> <IP_address> Mozilla/5.0+(Windows+NT+10.0;Win64;+x64)+AppleWebKit/537.36(KHTML,+like+Gecko)+Chrome/114.0.0.0+Safari/537.36 https://<hostname>/ 500 0 0 29

The Analyzer is working as expected, all dashboards load as expected, and there are no failures in the nightly RiskFabric Processing job.

Environment

Version : 6.x

Component : Metrics

Cause

The file RiskFabric.Collector.dll in the Risk Fabric Server Web folder on the application (IIS) server is either corrupted or was not updated during an upgrade from an older version of ICA.

Resolution

In the event the RiskFabric.Collector.dll file has been corrupted or failed to update during an upgrade, the probability is high that other files were similarly affected. The recommended resolution is to restore the application from a backup or upgrade to the latest version of ICA. If neither option is available to you, contact Broadcom support for assistance.