Inventory Sync fails in Aria Lifecycle Manager with error “LCMVRLICONFIG40004": Invalid host name provided for VMware Aria Operations for Logs”
search cancel

Inventory Sync fails in Aria Lifecycle Manager with error “LCMVRLICONFIG40004": Invalid host name provided for VMware Aria Operations for Logs”

book

Article ID: 403920

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

While initiating the Inventory Sync for VMware Aria Operations for Logs from VMware Aria Suite Lifecycle Manager (vRSLCM), the operation fails with the following error message:

The following error was captured in the /var/log/vrlcm/vmware_vrlcm.log:

2025-07-07T08:04:04.924Z ERROR vrlcm[1359] [pool-3-thread-49] [c.v.v.l.p.v.VrliImportEnvironmentTask]  -- Invalid hostname provided for VMware Aria Operations for Logs import. Please check the hostname and retry again.
java.lang.RuntimeException: Cannot execute ssh commands. Exception encountered : null
        at com.vmware.vrealize.lcm.util.SshUtils.execute(SshUtils.java:727) ~[lcm-util-8.18.0-SNAPSHOT.jar!/:?]
        at com.vmware.vrealize.lcm.util.SshUtils.runCommand(SshUtils.java:532) ~[lcm-util-8.18.0-SNAPSHOT.jar!/:?]
        at com.vmware.vrealize.lcm.util.SshUtils.runCommand(SshUtils.java:510) ~[lcm-util-8.18.0-SNAPSHOT.jar!/:?]
        at com.vmware.vrealize.lcm.util.SshUtils.runCommand(SshUtils.java:624) ~[lcm-util-8.18.0-SNAPSHOT.jar!/:?]
at com.vmware.vrealize.lcm.plugin.vrli.VrliImportEnvironmentTask.execute(VrliImportEnvironmentTask.java:174) [vmlcm-vrliplugin-core-8.18.0-SNAPSHOT.jar!/:?]

The issue prevents successful inventory import of the Aria Operations for Logs environment into Lifecycle Manager.

Environment

VMware Aria Suite Lifecycle Manager 8.x
VMware Aria Operations for Logs 8.x

Cause

The issue is caused by a failure in SSH communication between Aria Lifecycle Manager and Aria Operations for Logs. This may result in the hostname resolution or retrieval logic returning null or empty, leading to the error.

Resolution

To resolve the issue:

  • Restart Aria Operations for Logs nodes. This ensures that all services including SSH are running properly and clears any transient issues.
  • SSH to vRLI master node from vRSLCM appliance and vice versa. If it stuck or hang then check with networking team. 
  • Retry Inventory Sync from Aria Lifecycle Manager.

Additional Information

Enabling FIPS on Aria Lifecycle Manager alone does not resolve the issue.

Ensure that the correct FQDN or IP address of Aria Operations for Logs is configured and that network connectivity and DNS resolution are working between the Aria Suite Lifecycle Manager and the target system.

Ensure SSH port (typically 22) is accessible and that credentials used by LCM have proper privileges.