Seeing intermittent error in APM leading to polling/discovery impact
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Seeing intermittent error in APM leading to polling/discovery impact

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Article ID: 403910

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Below error is seen in the IP domain logs as well as in  the device discovery error info.

SNMP-EAGENTUSMWINDOW-Agent REPORT [USM]: Not In Time Window.

Environment

All supported releases of Smart

Cause

Same SNMP EngineID is used by multiple devices.

Resolution

Verify if same SNMP EngineID is used by multiple devices. One of the way is to check using tcpdump. If so, then by adding parameter SM_SNMP_ALLOW_DUP_ENGINEID=1 in the runcmd_env.sh will take care of handling any duplicate EngineID configured between the devices. PFB the stpes to implement the same:

  • Delete all the devices from IP domain. If deleting all the devices is not possible then continue with the below steps.

  • Clear LCD table using below commands:

    • dmctl -s <APM Domain> exec dmdebug --dumpLcd --output=output.txt|tee

    • dmctl -s <APM Domain> loadModel sm_snmp_lcdmgr|tee

    • dmctl -s <APM Domain> create SM_SNMP_LcdMgr::lcd|tee

    • for i in `cut -d":" -f1 output.txt|cut -d"=" -f2|grep -v LCD`; do dmctl -s <APM Domain> invoke SM_SNMP_LcdMgr::lcd removeEngineData ${i} 161 | tee; done

  • Add parameter SM_SNMP_ALLOW_DUP_ENGINEID=1 in runcmd_env.sh file.

  • Restart APM01 and discover all the devices.

NOTE: On the long run, request to have unique SNMPEngineID just to comply with the RFC.