VMware Chargeback upgrade from version 8.10 to 8.16 process appears to be stuck
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VMware Chargeback upgrade from version 8.10 to 8.16 process appears to be stuck

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Article ID: 403880

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

The upgrade of VMware Chargeback from version 8.10 to 8.16 gets stalled. Although the process has been running for many hours, the /opt/vmware/var/log/vami/vami.log do not indicate any errors, showing only a continuous "running in the background" status.

Environment

  • VMware Chargeback 8.10
  • VMware Aria Operations 8.16.x

Cause

Known issue with the Aria Operations charge back tenant app version 8.10.1.

Resolution

Fixed in the next release.

Workaround:

The engineering team has shared the hotfix which needs to be applied on Tenant App 8.10.1.

  1. Login to Tenant App Console using root credentials.  
  2. Upload the zip file "tenant-app-upgrade-package.zip" attached to the Tenant App to /tmp directory.
  3. Extract the zip file using the command: unzip tenant-app-upgrade-package.zip
  4. Change the permission of the extracted script file, using: chmod u+x Tenant_HF_Upgrade_unix.sh
  5. Execute the Script using the command: ./Tenant_HF_upgrade_Unix.sh
  6. The script will enforce a reboot on the machine after RPM installation. Please comment suitably if the restart needs to be done manually, restart is a must for the new changes to commit.
  7. Tenant App version can be verified, by using "rpm -qa | grep tenant-app", which in response should return updated Package information.

Attachments

tenant-app-upgrade-package.zip get_app