Unable to Add Hosts to vCenter or Hosts Disconnected/Not Responding in vCenter After Breaking LACP/Port-channel Bond at Upstream Physical Switch
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Unable to Add Hosts to vCenter or Hosts Disconnected/Not Responding in vCenter After Breaking LACP/Port-channel Bond at Upstream Physical Switch

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Article ID: 403861

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

ESXi hosts lose network connectivity and cannot be managed in vCenter after port-channel configuration is removed from upstream physical switchports, and one of the following scenarios is true:

  • The management vmkernel is on a distributed switch port group using a LAG for it's uplinks.
  • The management vmkernel is on a distributed switch port group using IP Hash load balancing. 
  • The management vmkernel is on a standard switch port group using IP Hash load balancing. 

Environment

VMware vCenter Server

VMware vSphere ESXi

Cause

When a LAG/port-channel bond is in use, network traffic is hashed across all interfaces in the bond. This is different than the other load balancing methods available, which will pin each VM/vmkernel's traffic to a single vmnic, and traffic for any individual MAC must be sent and received over the same vmnic. 

If this configuration is broken on one side and not the other, it is expected that traffic will get dropped because the upstream physical switch and ESXi are now load balancing differently. The load balancing must match exactly between ESXi and the upstream physical switch. 

Resolution

To move from a bonded configuration to a non-bonded configuration, or vice versa, it is best to change the configuration on one upstream physical switchport at a time so you can walk active connections on ESXi over to a new vSwitch or portgroup without losing connectivity. 

This process is outlined in KB 312554, under the section "Assign NICs to the LAG". 

 

Additional Information