IA Mainframe Trace Data Not Visible on Secondary server
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IA Mainframe Trace Data Not Visible on Secondary server

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Article ID: 403819

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Updated On:

Products

DX APM SaaS DX Operational Observability

Issue/Introduction

We have successfully configured a secondary server to collect metric and trace data from the mainframe. The Kafka broker is set up on the primary server.  While we were able to retrieve trace data for a few days, we have recently noticed that the trace is no longer visible on the secondary server, although it is still accessible on the primary server.

In the Agent log, we noticed this ERROR, could it be the root cause?

[WARN] [IntroscopeAgent.Mainframe] The clamp limit of 50000 messages has been reached in the asynchronous logging queue. No more new log messages will be added.
java.lang.Throwable: Clamp limit reached

Environment

  • DX O2 SaaS

 

Cause

  • The mentioned log entry is expected given the current high volume of DEBUG logs, but it does not indicate any functional issue.
  • Based on logs, No data is available in the configured Kafka topic for processing.

     [INFO] [IntroscopeAgent.Mainframe] kafkaConsumerPool--0 -> No records since last #1000 polling intervals.

Resolution

Ensure you are receiving SMF binary messages to the Kafka zab topic from the ZAB component.

You can refer to Techdocs Broker Extension