Changes done to Action Names are not visible to the user when using a non English language
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Changes done to Action Names are not visible to the user when using a non English language

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Article ID: 403814

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Changes done to Action Names are not visible to the user when using a non English language

STEPS TO REPRODUCE:

  1. Classic PPM > Administration > Data Administration > Processes
  2. Create a new process.
  3. Add an action on the Start step and link it to the Finish step
  4. Log in with a user with Spanish as a language (or any other)
  5. Edit the process and go back to the Start process
  6. Change the step name to MySpanishStep
  7. Save the changes and these are visible to the user
       Table query:
       SELECT * FROM cmn_captions_nls WHERE name = 'MySpanishStep' AND TABLE_NAME = 'BPM_DEF_STEPS'
       The caption update is done at language_code ='es' (update done to Spanish record)
  8. Change the name of the action on the step to MySpanishAction
  9. Save the changes

Expected Results: The action name to be updated.
Actual Results: The action name did not get updated
   Table query:
   SELECT * FROM cmn_captions_nls WHERE name = 'MySpanishAction' AND TABLE_NAME = 'BPM_DEF_STEP_ACTIONS'
   The caption update is done at language_code ='en'

Environment

Clarity 16.2.X, 16.3.0, 16.3.1, 16.3.2

Cause

This is caused by DE172937

Resolution

This is fixed in Clarity 16.3.3

Workaround: Change the language of the user to any other and use the translate icon to add the new action caption to the desired language