Error: "Cannot validate proxy configuration. Proxy server was not reachable with specified host and port." / "No route to host"
search cancel

Error: "Cannot validate proxy configuration. Proxy server was not reachable with specified host and port." / "No route to host"

book

Article ID: 403706

calendar_today

Updated On:

Products

VMware Cloud Foundation VMware SDDC Manager

Issue/Introduction

When a proxy is configured in the VCF 9.0 Installer, "Connect to the online depot" fails with the error:

Cannot validate proxy configuration. Proxy server was not reachable with specified host and port.

The Operations Manager log shows the following error:

Log Location: var/log/vmware/vcf/operationsmanager/operationsmanager.log

Error testing proxy at <Proxy_Hostname>:8080 connecting to https://dl.broadcom.com.
java.net.NoRouteToHostException: No route to host

Environment

VCF Installer 9.0.

Cause

This issue occurs when there is no route between the VCF Installer and the proxy server. This means the server can't resolve the route for the next hop or has no route defined at all.

Resolution

The VCF Installer must be able to route to the configured proxy server for online depot connectivity to work. The below steps can help validate routing connectivity. 

  1. Login to the VCF Installer:
    • SSH into the VCF Installer using the vcf account.

  2. Review networking details on the VCF Installer 
    • Review network information for the VCF Installer using the nmctl command:

      nmctl
  3. Verify connectivity is working to the proxy with ping & traceroute 
    • Run the following command on the VCF Installer command line:

      ping <proxy_hostname> 

      traceroute <proxy_hostname>

      Note: Replace <proxy_hostname> with the proxy configured.

Additional Information