Data Not Populating on Wavefront portal
search cancel

Data Not Populating on Wavefront portal

book

Article ID: 403695

calendar_today

Updated On:

Products

Observability DX OpenExplore

Issue/Introduction

Stopped receiving data for external endpoints connectivity on wavefront. Proxy endpoints are visible.

Metrics collected via Telegraf Agents and sent to proxies for ingestion are missing from Dashboards or Charts. 

Environment

  • Telegraf Agent
  • Tanzu Kubernetes Grid Intergration
  • Tanzu Application Services

Cause

Telegraf logs show errors on input/output configuration. Examples: incorrect DNS entries, Missing Port#, or possible Environmental variables not set correctly.

Resolution

Telegraf Agent collects, also referred to as "scrapes", metrics then sends the metrics to a DXOE Proxy for ingestion into the tenant.

After review of the proxy logs and ruling out errors connecting to the DX OpenExplorer backend, investigate the Telegraf logs for errors. See Telegraf Troubleshooting

A few Integrations that commonly use a Telegraf Agents are:

 

Key Points:

  1. Review Telegraf Agent logs, identify any errors in authentications, permissions, networking ect.
  2. Verify if errors are related in [[inputs.<source>]] OR [[outputs.wavefront]]
  3. For input errors, refer to the documentation for that product, and if necessary, engage the specific support team.
  4. For output errors see our Telegraf Troubleshooting article.

Additional Information


If you're still encountering this error after following these steps, please contact Wavefront Support with your configuration details and logs.