DX NetOps Portal Topology Performance tab returns an error
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DX NetOps Portal Topology Performance tab returns an error

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Article ID: 403520

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

When going to Inventory->Topology in the Network Observability DX NetOps Portal web server web UI the Performance tab shows an error message.

The error shows in a red box with the title "Service Unreachable" next to a Yield sign symbol. There is a Retry button to attempt to reload the tab.

The red box shows an error that states "We are currently unable to connect to the Service. Try again later, or contact the administrator if the issue persists."

Environment

All supported Network Observability DX NetOps Portal web server releases

Cause

Missing configuration in the Portal console service (default path shown) /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties configuration file.

These variables are missing the required values.

  • graphql.protocol=
  • graphql.host=
  • graphql.port=
  • graphql.endpoint.query=

Resolution

Make a backup copy of the portal.console.properties file.

  • cp /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties.orig

Edit the file and set the following values.

  • graphql.protocol=http
  • graphql.host=<DA_IP_Address_or_HostName>
  • graphql.port=8080
  • graphql.endpoint.query=/graphql

After making the changes to the portal.console.properties file restart the caperfcenter_console service to read in the changes.

  • Stop the service: systemctl stop caperfcenter_console
  • Start the service: systemctl start caperfcenter_console