Export in Progress Banner Stays longer
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Export in Progress Banner Stays longer

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Article ID: 403478

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise Clarity FedRAMP

Issue/Introduction

The 'Export in Progress' banner remains visible for an extended period after initiating a CSV export. Additionally, the exported file does not appear automatically under the notification bell icon, requiring a manual browser refresh to view the download

Steps to Reproduce: 

  1. Login to Clarity in MUX
  2. Navigate to workspace like Idea/Project
  3. Use the action button and Export to CSV

Expected Result: The banner Export in Progress should go away fairly quick and attachment should be visible under notification bell icon 

Actual Result: The banner Export in Progress stays longer and manual browser refresh is needed to get the output visible under notification bell icon 

Environment

All Clarity supported release 

Cause

  • This behavior is observed when the Microservice Broker is not implemented. After the CSV export is completed, the pull notification responsible for updating the bell icon executes at 1.3-minute intervals, resulting in a noticeable delay in displaying the output file and banner stays on the screen 
  • This behavior can also be seen if the Microservice Broker is not working properly and needs to co-related by reviewing the broker logs. 

Resolution

  • Implement the Microservice Broker as documented
  • Review the broker logs for any anomalies