Opening UI throws A JNI error has occurred
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Opening UI throws A JNI error has occurred

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Article ID: 403474

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

When attempting to open the UI, an error like:

When launching the runclient.jar, the following error pops up:

Error: A JNI error has occurred, please check your installation and try again

 

This can happen when attempting to start the UI with Java 11 on a server with other versions of java or where the user cannot update the PATH environment variable like you see on a VDI desktop.

Opening the command line and running the command:

java -version

returns a different version of java than the one that desired version.

Environment

OS: Windows
Version: Any
Component: Client/UI

Cause

This is caused by multiple versions of java and being unable to update the %PATH% environment variable at runtime

Resolution

Ultimately an OS admin should be consulted on why %PATH% cannot be updated and why java -version brings back an unexpected version.

The client.properties file might be able to have it's JAVA_HOME= setting updated to the desired java path

If that does not work, a possible workaround can be to create a .bat file called something like runme.bat in the client's main folder and put in a line like:

"{Full path to desired version of java}\bin\javaw" -jar RunClient.jar

You can also open a windows command prompt, cd to the folder with runclient.jar, and run the command above manually.