Insight report launch from the CA SDM failed with "AHD04405:CA Service Desk Manager system internal error"
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Insight report launch from the CA SDM failed with "AHD04405:CA Service Desk Manager system internal error"

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Article ID: 403356

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Jasper and SDM integration succeeded, but launching the "Insight Report" from the CA SDM button failed with error "AHD04405: CA Service Desk Manager system internal error." This affected all analyst users except for the service account. Analysts' login with their z##### (a domain account) receive the message "Problem creating Jasper Profile. Error: Exception occurred while creating user."

As per snippet network trace shown below for the working and nonworking users, the request headers are same, and it has "Pragma" header with empty value and "Cache-Control: Private"

Environment

JasperReports Server 8.x, 9x

 

Cause

The problem stemmed from the Web Application Firewall/ WAF policy configuration, which blocked HTTP requests lacking headers value, as per a predefined rule.

Resolution

Pragma: (empty) is syntactically valid but not useful. It is ignored by most servers and proxies. This header is used by HTTP/1.0 version for backward compatibility and mostly the server may ignore this. As the purpose is solved by the Cache-Control header.  Cache-Control: private is a valid header that prevents shared (proxy) caches from storing the response but allows the browser (client) to cache it. This combination or coexistence of both the headers is not a vulnerability. The customer is advised to work with their WAF team and adjust WAF policy configuration to resolve the issue.