Unable to expand hard disk size and change storage policy on the VM
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Unable to expand hard disk size and change storage policy on the VM

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Article ID: 403221

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Updated On:

Products

VMware vSAN VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

Symptom:

  • No critical errors seen on skyline health.

  • No issues seen with vSAN objects.

     

    $ esxcli vsan debug object health summary get
    Health Status                                              Number Of Objects
    ---------------------------------------------------------  -----------------
    remoteAccessible                                                           0
    inaccessible                                                               0
    reduced-availability-with-no-rebuild                                       0
    reduced-availability-with-no-rebuild-delay-timer                           0
    reducedavailabilitywithpolicypending                                       0
    reducedavailabilitywithpolicypendingfailed                                 0
    reduced-availability-with-active-rebuild                                   0
    reducedavailabilitywithpausedrebuild                                       0
    data-move                                                                  0
    nonavailability-related-reconfig                                           0
    nonavailabilityrelatedincompliancewithpolicypending                        0
    nonavailabilityrelatedincompliancewithpolicypendingfailed                  0
    nonavailability-related-incompliance                                       0
    nonavailabilityrelatedincompliancewithpausedrebuild                        0
    healthy                                                                 2228

  • VM1's hard disk 1 cannot be expanded and is greyed out. Also the disk file is pointing to #-xd-delta.vmdk file.


  • If we clone the same VM, the new cloned VM can be expanded and the file name is not having "###-xd-delta.vmdk" and the hard disk 1 is not greyed out.

Environment

VMware vSphere vSAN

Cause

Host is unable to expand the size of the datastore from vCenter since the VM is running on snapshot.

  • Creating the snapshot disallows the host to change the size of the hard disk of the VM.

  • In this case the VDI VM and the snapshot is not generated manually from the vCenter.

    Note: The “xd-delta.vmdk” suffix is commonly observed with VDI (Virtual Desktop Infrastructure) solutions such as Citrix, often representing disks that are part of machines provisioned by technologies like Citrix MCS. For example, you might see “harddisk-xd-delta.vmdk” on VMware ESXi VMs created by Citrix MCS.

    Refer - HPE SimpliVity - SimpliVity VM Backup Scattered VMDK Failure - Citrix Desktops Provisioned Via MCS

Resolution

  • Please reach out to the respective VDI vendor to solve the disk issue for the VM generated by their tool.

  • As a workaround, you can create a clone VM using the original one and use then expand the hard disk size on the cloned VM.

    Refer - Clone an Existing Virtual Machine