'Actions' menu of 'Time & date' is not working in ESXi host client starting from 7.0
search cancel

'Actions' menu of 'Time & date' is not working in ESXi host client starting from 7.0

book

Article ID: 403181

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Starting from 7.0, the 'Actions' menu of 'Time & date' fails to respond — clicking it does not trigger any visible drop-down or options. It is no longer able to use this menu to modify NTP settings.

Environment

VMware ESXi 7.0

VMware ESXi 8.0

VMware ESXi 9.0

Cause

This 'Actions' menu for 'Time & date' on ESXi host client previously offered the following three functions for NTP service,

1. Edit settings

2. Change NTP service startup policy

3. Restart / Start / Stop NTP service

As of ESXi 7.0, this menu is no longer operational.

Resolution

Equivalent functionality remains available through the host client. Those three functions can be performed as follows,

  1. Edit settings

    Click the 'Edit NTP Settings' button located to the left of 'Actions' menu. This provides access to modify NTP settings.


  2. Change NTP service startup policy

    Once you click 'Edit NTP Settings', the 'NTP service startup policy' will be shown in the popup dialog



  3. Restart / Start / Stop NTP service

    Go to Manage -> Services, locate the ntpd service, and use the buttons at the top of the tab to Start or Stop or Restart it.