Local admin account gets locked shortly after password change
search cancel

Local admin account gets locked shortly after password change

book

Article ID: 403177

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Changing the admin user's password via Aria Suite Lifecycle results in the account being locked within minutes of changing the password.
  • The "admin" user for GUI access is constantly locked out.
  • If the admin user password with which Aria Operations for Logs was installed is restored, the user is not locked out.
  • The lock happens only when the password is changed.
  • The admin user can be unlocked from the appliances, but after a few minutes it locks out again.
  • The admin account may have been unlocked as per Reset and unlock the local admin account in VCF Operations for Logs and the account immediately locks again.

Environment

VMware Aria Operations for Logs 8.x

Cause

The integration from Aria Operations is configured using the Aria Operations for Logs admin user account and the password was not updated with the new value.

You can can confirm by:

    1. Signing into Aria Operations product UI
    2. Navigate to Administration > Integrations
    3. Expand VMware Aria Operations for Logs Adapter and Select the VMware Aria Operations for Logs Adapter instance
    4. Click Edit
    5. Click on Pencil icon beside the Credential
    6. Operations for Logs Username is admin

Resolution

  1. Log in to the Aria Operations UI as a user with permission to change credentials
  2. Navigate to Administration > Integrations
  3. Expand VMware Aria Operations for Logs Adapter and click the vertical three dots button next to the instance and select Edit
  4. Click Stop Collecting
  5. Unlock the VCF Operations for Logs admin account as per Reset and unlock the local admin account in VCF Operations for Logs
  6. Click the vertical three dots button and select Edit
  7. Click the Edit Credential button (pencil icon)
  8. Provide the new Operations for Logs Password and click OK
  9. Click Validate Connection and verify "Test connection successful" is received
  10. Upon successful validation, click Save
  11. Select the VCF Operations for Logs Adapter instance
  12. Click Start Collecting
  13. Allow for the 5 minute collection cycle and verify that the admin account no longer gets locked in VCF Operations for Logs.

Additional Information

To prevent the Aria Operations for Logs admin account from getting locked after future password changes, create a service account to use in the Aria Operations integration instead of using the admin account for collection.