Low Applicability Numbers for a Security Update
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Low Applicability Numbers for a Security Update

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Article ID: 403149

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Updated On:

Products

Patch Management Solution

Issue/Introduction

You may notice that, for some reason, the applicability of a certain security update is very low for your environment.  You know that you have the applicable software installed on many endpoints, and it should be at least applicable to these endpoints.

Environment

Patch Management 8.x

Cause

Missing data from catalog.xml file

Resolution

The first thing you check would be that the vendor for the security update is selected in the Import Patch Data for Windows task, under the Vendors and Software section:

After confirming that the vendor in question had already been selected, we can eliminate that as a primary cause.

The next step would be to review the catalog.xml file located on a client by default at "C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\ \{6D417916-467C-46A7-A870-6D86D9345B61}\cache", which you feel should apply to this security update and is not showing up as applicable.  Verify that there is a recent date modified relevant to the current date/time.

Next you should open this file and inspect it.  In this particular situation, the vendor was missing from the catalog.xml file.  For this example, we will see that the catalog.xml file is missing Adobe Acrobat Reader DC 25.  Specifically, <product name="Adobe Acrobat DC 25" /> and <product name="Adobe Acrobat DC 25 x64" />.

Back on the SMP server, it would be best to also inspect the Catalog.xml file to see if the problem is the same.  Check the local catalog.xml file located at:  Installation Drive for SMP Server (Default is:  C:\Program Files\Altiris\Patch Management\Packages\WindowsVulnerabilityScan)

Next step, on the SMP console, uncheck the incremental import option in the Import Patch Data for Windows task.

Make sure to click Save Changes.

Now run the PMImport task or wait for its regularly scheduled execution time.  Since unchecking the Incremental import, it will force the product to run a full import.  This will probably take over an hour to complete.  Once completed, check the catalog.xml file on the SMP server.  It should now be accurate, and you should see your applicability numbers increasing.