sm_service command doesn't work after vm patching
search cancel

sm_service command doesn't work after vm patching

book

Article ID: 403089

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

sm_service show command throws below error

sm_service show
[July 2, 2025 at 10:48:07 AM GMT+2 +958ms] t@1219417152 <Primary Thread>
CI-E-EFLOWID-For flow CI_FlowBufferedHead_U [Client Buffered Head] HEAD|BUFFERED @0x00000000011bf680
  . Read buffer, 0 bytes available of 2145
  . ?3?0000000000000000 0000000000000000 <^|0000000000000000 0000000000000000
  . Write buffer, 0 bytes written of 2048
  . ?3?[^0000000000000000 0000000000000000 0000000000000000 0000000000000000
  . ->CI_FlowPipe_U IN_FLOW|PHYSICAL|LOCAL @0x000000000117cf60
  . sm_service
 CI-EWHILE-While executing function "open"
 <SYS>-EACCES-Permission denied; in file "/work/redcurrent/DMT-2.4.0.0/1/smarts/clsapi/ci_flow.c" at line 3060

Environment

Smarts 10.1.x / 24.3.x

Cause

  • User not mapped to correct group in /etc/passwd file and hence no permission to run sm_service command.

         OR     

  • Environment variable SM_PIPEDIR value is set to /var/smarts/pipes/ instead of customized directoy.

Resolution

  1. Try running sm_service show command as sudo if it works correctly then no issue with Smarts application, its the environmental issue.

    cd <IP_HOME>/IP/smarts/bin
    sudo ./sm_service show
  2. Customer to check with server team or linux team and ensure that user used within Smarts application has required permission to run sm_service command.

  3. Also, ensure that correct value for environment variable SM_PIPEDIR is set. You can verify SM_PIPEDIR value being used using output of this command: bash -x sudo ./sm_service show

Additional Information

Please check /etc/passwd and /etc/group file to see if the user is correctly mapped to group and has required permission to execute the command.