'Cached Organization System' tasks fails from VMware Cloud Director UI
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'Cached Organization System' tasks fails from VMware Cloud Director UI

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Article ID: 403050

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • In the VMware Cloud Director (VCD) Provider portal, multiple 'Cached Organization System' tasks fails every 2 minutes.

Environment

VMware Cloud Director

Cause

The issue is caused by a naming convention conflict. When catalogs contain a '/' character in their names and have the "Enable early catalog export to optimize synchronization" option enabled, it alters the system's expected directory structure. Specifically, the '/' character results in the cache directory being nested, preventing the system from finding the expected UUID within parentheses, which ultimately leads to a StringIndexOutOfBoundsException.

Resolution

Broadcom is aware of this issue and this will be fixed in the upcoming release of VMware Cloud Director.

Workaround:

Follow the below steps to edit the catalog from the VCD tenant portal:

  1. Log in to the tenant portal as a system administrator or a provider role with the Catalog: Manage Distribution Settings and Catalog: View Distribution Settings rights.

  2. In the top navigation bar, click on Content Hub and select Catalogs from the left panel. A grid view of catalogs will appear.

  3. Click on the catalog that contains the '/' character in its name.

  4. Click Edit, modify the catalog name to remove the '/' character, and update the name accordingly.

  5. Save the changes to the catalog configuration.