Generating a log bundle in Aria Automation produces an error stating "Not enough disk space".
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Generating a log bundle in Aria Automation produces an error stating "Not enough disk space".

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Article ID: 402987

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When generating a log bundle of Aria Automation on the appliance itself, an error can be observed stating: "[ERROR] Will try to collect a smaller log bundle by limitting the collected files: Not engough disk space."

A log bundle may still be generated, however it will be missing most of the relevant files needed for troubleshooting issues.

In a similar context of low disk space, log bundles generated by Aria Lifecycle Manager may also be very small (sometimes around 2MB) and missing the relavant logs.

Usually, for a production environment (3-node cluster), a more reasonable log bundle size will be closer to hundreds of MB, or even several GB in size.

Environment

Aria Automation 8.x

Cause

This can be caused by exisitng/old log bundles present in the /home/root directory of an Aria Automation appliance, taking up the space required to generate a complete log bundle.

Resolution

Delete older log bundles either directly from the Aria Automation appliance, or from Aria Lifecycle Manager, and then generate a new log bundle.

From the appliance:

Open a SSH session to the Aria Automation appliance, and delete old log bundles under the /home/root directory.

Once the old log bundles are deleted, a new log bundle can be generated directly from the Aria Automation appliance with the command: vracli log-bundle.

From Aria LCM:

In the Aria Lifecycle Manager UI, navigate to Lifecycle Operations > Environments > click the elipses menu of the Aria Automation tile > Logs > Delete Logs.

Then, following the same menu path, select Generate Logs.