vSAN Integration Shows OK Status but No Data Collection in VMware Cloud on AWS
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vSAN Integration Shows OK Status but No Data Collection in VMware Cloud on AWS

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Article ID: 402980

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

In a VMware Cloud on AWS (VMC), vSAN integration within Aria Operations appears to be successful (status: OK), but no vSAN-related data is not being collected for the management cluster.

No data available for Capacity -> Disk Space (Demand)

Environment

Aria Operations 8.x

VMC on AWS

 

Cause

The issue was due to insufficient permissions of the integrated user. Specifically:

  • The user lacked the necessary privileges to calculate metrics such as:

    • Disk Space | Total Capacity (GB)

    • Disk Space | Utilization (GB)

  • In VMC environments, data for management cluster datastores (e.g., vsanDatastore) can only be collected if the user has CloudAdmin permissions and is part of the CloudAdmin group.

Resolution

Use with a account that:

  • Has CloudAdmin permissions

  • Is a member of the CloudAdmin group