Error: "Unable to connect to vCenter " when adding new VM replication to VMware Cloud Director Availability
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Error: "Unable to connect to vCenter " when adding new VM replication to VMware Cloud Director Availability

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Article ID: 402956

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Updated On:

Products

VMware Cloud Director Availability - Disaster Recovery 4.x

Issue/Introduction

  • Adding new VM replication to VMware Cloud Director Availability (VCDA) fails.
  • The error that's visible in the UI is "Unable to connect to vCenter'.
  • On the Replicator Service appliance in the log file /opt/vmware/h4/replicator/log/replicator.log the following error is visible:

    2025-06-25 06:19:33.475  INFO - [UI-########-####-####-####-########-####-##-##-##-##] [job-##] okenServiceImpl$RequestResponseProcessor : ns0:FailedAuthentication: Password of the user logging on is expired. :: Password of the user logging on is expired. :: User account expired: {Name: <username>, Domain: <domain name>}
    2025-06-25 06:19:33.475 DEBUG - [UI-########-####-####-####-########-####-##-##-##-##] [job-##] com.vmware.h4.replicator.vc.VcConnector  : Unable to connect to VC ########-####-####-####-########
    com.vmware.vlsi.client.sso.SsoException: com.vmware.vim.sso.client.exception.PasswordExpiredException: ns0:FailedAuthentication: Password of the user logging on is expired. :: Password of the user logging on is expired. :: User account expired: {Name: <username>, Domain: <domain name>}
            at com.vmware.vlsi.client.sso.SsoException.toSsoEx(SsoException.java:35)

Environment

VMware Cloud Director Availability 4.7.3

Cause

This issue occurs when the password of the user account used to register the lookup service is expired. Therefore authentication from VCDA to the lookup service fails.

Resolution

To resolve this issue

  1. Ensure that the user account is reset with valid password.

    Note: The name of the user account is mentioned within the error message visible within the log /opt/vmware/h4/replicator/log/replicator.log as seen above.

  2. Login in the VCDA manager service using the root credentials at https://Cloud-Replication-Management-Appliance-IP-Address:8441/ui/admin
  3. On the settings menu in the Lookup Service field click on edit and fill up the Lookup service details
  4. Click 'Apply'