vSan data inaccessible after shutdown/startup
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vSan data inaccessible after shutdown/startup

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Article ID: 402951

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Updated On:

Products

VMware vSAN

Issue/Introduction

After a cluster shutdown then startup, vSAN objects are showing as inaccessible as well as VMs
This can be seen in a number of areas in the UI 

From the ESXi host web client the VMs show invalid. 

Environment

vSAN (All) 

Cause

This is caused by a host still being in vSAN decom / maintenance mode. 
When a host is in vSAN Decom / Mainteance mode this host will not contribute storage to the cluster and is seen as a failure
Even with a storage policy that has a failures to tolerate of 1 or greater, Based on the order hosts were shut down, even a single host still in a Decom / maintenance mode can cause objects to be inaccessible. 


When going to Cluster > Monitor > Skyline Health there will be an alarm for Host Maintenance Mode 
(the following screen shot may differ based off version) 



Running esxcli vsan cluster get  via CLI will show output similar to below:

Resolution

1. Confirm if there are any VMs running on the host via vCenter or host UI and migrate them off or shut them down. 
2. One host at a time, place the host(s) that are in this state in to maintenance mode with no action / no evacuation using vCenter or host UI 
3. Remove the host from maintenance mode in the same manner as above and proceed to any other hosts that are in this state. 

Additional Information