The Report Manager server is not working and it shows as failed in the CAPM Datasource.
search cancel

The Report Manager server is not working and it shows as failed in the CAPM Datasource.

book

Article ID: 402933

calendar_today

Updated On:

Products

Network Observability CA Performance Management Spectrum

Issue/Introduction

When running systemctl srm-rib status we can see:

MMM DD HH:MM:SS hostame systemd[1]: Starting NetOps Report Manager Service...
MMM DD HH:MM:SS hostname srm-rib.sh[<pid>]: Starting Jetty: Already Running <pid>!

Environment

DX NetOps 24.3.1 and later

Cause

Stale PID file left from earlier service termination

Resolution

Delete the stale PID file:

Default location:

/opt/SRM/srm-rib/bin/srm-rib.pid

Start the service:

systemctl start srm-rib