Agent is not showing on the UI after successful installation or upgrade of agent
search cancel

Agent is not showing on the UI after successful installation or upgrade of agent

book

Article ID: 402853

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

The Aria Operations for Logs agent is installed on Linux VM via RPM.

Liagentd service is confirmed running with command: systemctl status liagentd

liagent.ini is properly configured to point to destination Aria Operations for Logs hostname.  However, Agent is not showing on Aria Operations for Logs UI.

Environment

Aria Operations for Logs 8.x

Cause

Endpoint VM is rejecting peer self-signed certificate.

Certificate is not found in /var/lib/loginsight-agent/cert/ folder.

Resolution

Update the liagent.ini configuration to accept any ssl cert from the Aria Operations for Logs environment:

  • SSH into the Linux endpoint VM.
  • Issue command to edit the config file:   vi /etc/liagent.ini
  • Add the following entry to the config file:  ssl_accept_any=yes
  • Save the liagent.ini config file.
  • Perform a restart on the agent service: systemctl restart liagentd

Confirm newly installed agent is now showing on the UI.