Active Directory LDAP connection failing after trusted root certificate update
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Active Directory LDAP connection failing after trusted root certificate update

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Article ID: 402813

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Updated On:

Products

Management Center - VA

Issue/Introduction

Management Center setup to integrate with AD LDAPS server.

After making the Management Center LDAP changes to add the LDAP (not Active Directory LDAP) changes, a reboot of the device was enforced (after clicking 'Activate').

Realising that the trusted root for the LDAPS server was not added, the admin proceeded to add to the MC device.

When running an LDAP test from the Management center host as described here and using a test user from the LDAP user store, the test failed, revealing the following SSL handshake errors

[Root exception is java.lang.IllegalStateException: Cannot write application data until initial handshake completed)

Management Center logs reporting SSLHandshakeException errors, indicating the trusted root certificate was not imported.

Environment

Management Center.

LDAP Integration with Active Directory.

Cause

After updating the LDAP server's trusted root certificate, a restart of the Management Center device is needed.

Resolution

Restart the Management Center appliance.

A restart is enforced by default when making UI based LDAP configuration changes, but not when the changes are done via the CLI.