Newly added users in Active Directory cannot access Aria Suite URLs via VMware Identity manager
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Newly added users in Active Directory cannot access Aria Suite URLs via VMware Identity manager

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Article ID: 402734

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Active Directory is already configured in vIDM and previously added users are able to login using vIDM.
  • New users have been added to Active Directory.
  • When the newly added users attempt to access Aria Suite URLs via vIDM, the Error: "Your username or password is incorrect." is displayed.
  • In the vIDM 'Users & Groups' page, these new users are not visible under Users or in respective groups.

Environment

VMware Identity manager 3.3.7

Aria Suite 8.x

Cause

Users not synced in vIDM from Active Directory.

Resolution

  1. Go to Active Directory and click on View and enable Advanced Features



  2. Right click on the User and click Properties, then navigate to the Attribute Editor tab and copy the value under 'distinguishedName' field by double clicking on it.




  3. Go to vIDM UI, click on the Identity and Access manager page, find and click on the directory name and then click on sync settings.
  4. Under the Users tab, manually add the user DN copied from step 2 and click save and sync



  5. In the Review page that follows, scroll down and make sure that no Errors are found like "Missing required attributes lastName" or "userPrincipalName" for the respective user.
    If there are any missing required attributes, add these fields for the users in Active Directory before proceeding.
  6. After resolving above and syncing the directory you should be able to see these users in the vIDM 'Users and Groups' page.