Error with the CCS Application Server - Symantec Application Server Service will not start
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Error with the CCS Application Server - Symantec Application Server Service will not start

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Article ID: 402661

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite Control Compliance Suite Standards Database Control Compliance Suite Standards Module

Issue/Introduction

The CCS Application server service is not running and you get an error message when you try to start it manually.  Below is the error message that is displayed when attempting to start it manually.

The Symantec Application Server Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

Environment

CCS 12.6

CCS 12.7

Cause

In the Application Server log files, you may see the following error: (located C:\ProgramData\Symantec.CSM\Logs\AppServer folder)

In the AppServer.Service.<date\hash>.#.# log file:

20XX-06-25 XX:XX:XX.877,<date> 09:48:38.877,<hostname>,Error,AppServer.Server,AppserverService,7520,,9,.ctor,,0,1,"Server.Start: AppServer service startup/initialization failed : System.ArgumentException: Unable to open database connection
Parameter name: connectionString ---> System.Data.SqlClient.SqlException: Cannot open database ""CSM_DB"" requested by the login. The login failed.
Login failed for user '<CCS_Service_account_username>'.

Resolution

Check to make sure that the CCS CSM_Db and the CSM_Reports databases are up and running, and that the user that is specified in the error message above has permission to login to those databases and is able to connect to the databases as well.