Issue:
Transactions are missing or size exceeded messages are found in the agent logs.
Environment:
All supported DevTest platforms.
Cause:
By default, Application Insight has a transaction size limit to reduce overhead.
This default limit needs to be increased for each agent.
Resolution:
1. See attached document for screenshot
2. In the portal:
1) Click on "Settings" (left hand side)
2) Click on "Agents" (left hand side)
3) Click on correct agent.
4) Click on the "Settings" tab
5) Click on "Transactions"
6) * Adjust "Maximum object graph size"
7) Click on "Save" at the bottom of the page.
8) Click "VSE"
9) * Adjust the "Maximum graph size"
10) Click on "Save" at the bottom of the page.
3. Recapture transactions.
* Common values are: 500000, 1000000 and 2000000 (Smaller values are preferred).
<Please see attached file for image>
<Please see attached file for image>