UserDefined fields information is not persistent through SAM layers
search cancel

UserDefined fields information is not persistent through SAM layers

book

Article ID: 402548

calendar_today

Updated On:

Products

VMware Smart Assurance VMware Telco Cloud Service Assurance

Issue/Introduction

Symptoms:

  • When a UserDefined (UDF) field is updated in the top level SAM and then the lower level SAM is restarted, the respective UDF field is updated in the top level SAM with null or value from lower level SAM.
  • This can also be seen in the TicketID field as well as the Owner field on the Notifications which are updated based on user's actions.

Environment

Smarts 10.1.X, 24.3.X
TSCA 2.X

Cause

Below configuration is present in dxa-sam.conf to pass the UDF from the lower level SAM to a top layer SAM:

notification
attr    UserDefined1
attr    UserDefined2
attr    UserDefined3
attr    UserDefined4
attr    UserDefined5
attr    UserDefined6
attr    UserDefined7
attr    UserDefined8
attr    UserDefined9
attr    UserDefined10
attr    UserDefined11
attr    UserDefined12
attr    UserDefined13
attr    UserDefined14
attr    UserDefined15
attr    UserDefined16
attr    UserDefined17
attr    UserDefined18
attr    UserDefined19
attr    UserDefined20

With respect to TicketID and Owner options, it is suggested to ensure that the attributes TicketID and Owner fields are not propagated through this configuraiton. 

Resolution

In order to avoid UDF value or TicketID or Owner, to be propagated from the lower level SAM to the upper level SAM comment the required UDF in dxa-sam.conf followed by restart of the top level SAM. For example:

notification
#attr    UserDefined1
attr    UserDefined2
.
.
.
.
#attr TicketID
#attr Owner