Workload clusters seen as disconnected in the UI
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Workload clusters seen as disconnected in the UI

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Article ID: 402542

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

We logged in the TCA UI and see workload clusters in a disconnected state 

Environment

3.0

Cause

This indicates an expired, outdated kubeconfig file in the TCA and TCACP appliance

Resolution

  1. SSH into each control plane node of the guest cluster and run the kubeadm certs check-expiration command to validate the Kubernetes certificates.
    kubeadm certs check-expiration

  2. If the certificates are still valid, copy the kubeconfig context located at /etc/kubernetes/admin.conf from a single valid the control plane node.
    cat /etc/Kubernetes/admin.conf
    


  3. Next, go to the TCA Manager and update the cluster's kubeconfig in the Virtual Infrastructure section using the copied admin.conf file.

  4. Access the TCA-CP dashboard on port 9443 and update the cluster’s kubeconfig there as well using the same file.

  5. After both updates are complete, reboot the TCA Manager and TCA-CP appliances