Failover or failback fails with error "No hosts with hardware version '##' and datastore(s) which are powered on and not in maintenance mode available"
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Failover or failback fails with error "No hosts with hardware version '##' and datastore(s) which are powered on and not in maintenance mode available"

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Article ID: 402524

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • The recovery plan failed while performing failback with error :
    "No hosts with hardware version '##' and datastore(s) 'Datastore_Name' which are powered on and not in maintenance mode are available" 

  • vmware-dr.log on SRM at recovered site reports:

    (/var/log/vmware/srm/vmware-dr.log)

    YYYY-DD-MMTHH:MM:SS.#### verbose vmware-dr[#######] [SRM@#### sub=DrTask ctxID=######## opID=########-####-####-####-############-getDetailedRecoveryResult] [#####] Task 'dr.recovery.RecoveryHistoryManager.getDetailedRecoveryResult525' completed with result: (dr.recovery.RecoveryHistoryManager.DetailedRecoveryResult) {

    <---------- Truncated output ---------->

    -->       "                  <msg>No hosts with hardware version &apos;11&apos; and datastore(s) &apos;&quot;<Datastore-name>&quot;&apos; which are powered on and not in maintenance mode are available.</msg>",
    -->       "    </e>",
    -->       "  </faults>",
    -->       "          <msg>No hosts with hardware version &apos;21&apos; and datastore(s) &apos;&quot;<Datastore-name>&quot;&apos; which are powered on and not in maintenance mode are available. 
    No hosts with hardware version &apos;21&apos; and datastore(s) &apos;&quot;<Datastore-name>&quot;&apos; which are powered on and not in maintenance mode are available. 
    No hosts with hardware version &apos;11&apos; and datastore(s) &apos;&quot;<Datastore-name>&quot;&apos; which are powered on and not in maintenance mode are available.</msg>",

Environment

Site Recovery Manager 8.x

VMware Live Site Recovery 9.x

Cause

Recovery fails due to incorrect Resource Mapping which prevents VMs from accessing appropriate compute, network, or storage resources required during the recovery process.

Resolution

Follow steps provided below:

  1.  Before initiating failover or recovery operations, ensure that the correct network, resource pool, folder, and placeholder mappings are properly configured.

  2. Check to see if there are resource pools with same names under different clusters or datacenters at the same site, this can lead to this problem. Rename the list of resource pools having the same name as the list of resource pools under a different cluster/datacenter to a different name. Example : Resource pool-old

Renaming the resource pools will fix this error.

If you are unable to rename, remove stuck protection group and recovery plan using SrmDbTool. Refer to the document for SRM DB-Tool usuage How to use SRM 8.X DB-Tool integrated with SRM Appliance

Recreate Protection Group and Recovery plan.

Note:  vCenter won't allow you to power ON these VMs as it knows that a recovery or failover was triggered. Remove these VMs from vCenter inventory at production site as the power ON icon is grayed out and re-register them from their respective datastores. Before removing them, please note down names of datastores where they are located.